Back to overview
Ubisoft connection with servers problem
Jun 14 at 03:07pm CEST
Resolved
Jun 14 at 03:07pm CEST
Company Ubisoft had MAINTENANCE to 5:00 PM
Affected services
Resolved
Jun 14 at 03:07pm CEST
Company Ubisoft had MAINTENANCE to 5:00 PM
Affected services